Cannot enable private -> public repo for codecov

@tom as requested opening a new issue.

I changed organisation repo amsa-code/sgb-decoder from private to public on github. amsa-code has all permissions set for codecov (app installed). My personal account has full permissions on amsa-code (organisation). The travis build seems to report the test results to codecov without error (unless suppressed by the script) and when I go to the codecov page I don’t see any report. Using my personal codecov login, Settings on that project in codecov says the project is not enabled and suggests that I “Find Repository Access and add sgb-decoder to the list.”. When I try to add that repo in codecov it seems to accept it but the project remains disabled in the settings for that repo in codecov. Can you enable it for me please (or fix the behaviour)?

@davidmoten can you provide a commit SHA and the Codecov output from Travis?

Thanks @Tom. Problem was mine. Jacoco wasn’t configured properly for codecov and I hadn’t exploded the codecov node in the travis log so didn’t notice the issue. All working now.

1 Like