Can't access Organization private repos

Hi,

I have issues accessing my organization private repos. It says I need to ask for account activation but I’ve been using codecov for quite a while now and haven’t had to ask for anything before.
I can see all private repos but can’t access them.

I also can’t access organization settings as I’m getting a 500 error.

Can somebody help me with this?

Thanks

Hi @tbekaert, I think this is an issue that is happening with our incident here. I recommend logging out, clearing cookies, and re-logging in. Then going to codecov.io/gh and resyncing your repositories. Let me know if that isn’t a suitable workaround for now.

Hi @tom,

I’ve tried that among other things:

  • Try in a private navigation tab
  • Revoke Codecov access to my github and grant it again

But no luck so far and I’m still stuck :frowning:

Hi @tbekaert, thank you for working on us here. We pushed a fix recently to the above incident. Are you able to access the organization settings now? Could you supply a codecov URL here?

Hey again,

No luck with your latest fix…

I’ve sent to you the codecov url of the organization along side with a link to the repo I want to see

Thanks for your help

1 Like

Hi, I got the same issues.
On my github organization account, there’s already one repo linked to codecov. Yesterday, i wanted to add another repo, this repo currently not configured yet. Today when i want to access my token from repo settings, i got same 500 error.

Thanks

@tanurwijaya10, can you message me the org and repo, as well as your github username?

Confirming that we have fixed the issue for you @tbekaert.

Confirming this has been fixed for you @tanurwijaya10.

1 Like

Solved, thanks for your help @tom

Same issue, can somebody help me please?

I had a similar problem and the issue was that my organization had restricted access to apps. So following:
https://docs.github.com/en/organizations/restricting-access-to-your-organizations-data/enabling-oauth-app-access-restrictions-for-your-organization
and
https://docs.github.com/en/organizations/restricting-access-to-your-organizations-data/approving-oauth-apps-for-your-organization

I was able to solve the problem.

1 Like

Thank you @roberto, @Edr is that helpful or do you still experience an issue?