Codecov status stuck at "waiting for status to be reported" on github

I used -g option to exclude some deps directories seem’s to work now

1 Like

Awesome! Thanks for letting us know.

I currently have the same problem, see for example

Reports apparently have been uploaded correctly. The corresponding status is never updated, though.

Hi @localheinz

Can you share the commit sha and output from the upload step?

We are having the same issue.

The report has been uploaded correctly but the corresponding status is no longer updated.

Any updates on this one? We are still having this problem with all our builds. :cry:

E.g. here: https://github.com/contao/contao/pull/1590

Hi! We have this exact same problem. Neither re-running the pipeline fixes this issue.

We’re currenlty with a couple PRs open beause of this. It’s a private project and it belongs to a paid codecov.io organization.

Anyone from support team could take a look and help us debug this issue? I can give more information about the project if needed.

Thanks

@drazisil @jerrod

@drazisil Is this thread still active or should I open a new one?

This is happening on our oss project again (last time was August 2019). Can we get an update please?

I have already tried pushing new commits to kick it off again but still having same problem.

Same issue at getsentry/sentry-php. The status is not a required GitHub status check if it matters for some reason, and for all recent commits I keep seeing the message “Notifications are pending CI completion. Waiting for GitHub’s status webhook to queue notifications.” on Codecov, although the builds finish. It seems that something got stuck and it’s affecting all new commits and PRs, and forcing the send of the status doesn’t work either

Hey @stefano93, @mydiemho, @leofeyer, @igorgcosta! Thanks for reaching out, sorry for the issue.

We believe that this has to do with rate limiting on the Github API (and yes, that means the error message is not very correct):

  1. We are in active conversations with Github’s partnerships team and PM’s to see what is possible here.

  2. An immediate possible workaround is, if you aren’t already is to use the Github App connection vs. an Oauth App/Team Bot: https://github.com/apps/codecov

We will continue to update as we make progress with Github team.

Jerrod

@jerrod Thank you for your feedback. We are already using the GitHub App but it is still not working. Let’s wait and see about the API rate limit.

@jerrod I switched to the GitHub App and for one PR it seemed to work fine, but then on a plain new commit I got the error There was an error processing coverage reports.

Getting this too, it’s really taking up a lot of time trying to get the codecov reports to come back.

An immediate possible workaround is, if you aren’t already is to use the Github App connection vs. an Oauth App/Team Bot: https://github.com/apps/codecov

We are using the app already for our organization, and have been getting this issue pretty consistently. The codecov bot replies to all the PRs, but it never updates the status.
Is there a reason why codecov always waits for all statuses to report before reporting its own status? Is there a way to disable this behaviour?

@Visate, Can you open up a new thread regarding never getting a status?

As documented here, we check all CI status checks to ensure every commit has accurate coverage. If you want to bypass this, you can set require_ci_to_pass to false documented here.

1 Like

Checking again 6 weeks later and sadly, it is still not working for us. :cry:

Hi @leofeyer, could you share a recent SHA and full Codecov output so we can help debug?

Sure, here you go:

Would you try using checkout@v1 for your action? We have seen this issue here, and I want to make sure this isn’t the reason you’re not getting a status check back.

edit: we do not recommend using checkout@v1 over checkout@v2