GitHub repo names and status not updating

Hi

Description

the link to GitHub suffers a delay and sometimes the data does not update. With data I refer to things like name of repos and private/public status. I have many repos showing up with wrong names and wrong status.

As an example I have a repo FelixErnst/EpiTxDb, which is public, but codecov still shows it as private.

Repository

https://codecov.io/gh/FelixErnst/EpiTxDb

Steps to reproduce

  1. Click on the repo

Expected behavior: The repo should be accessible, since it is public on GitHub
Flakiness?: Didn’t change in the last 48h.

Versions
Win10 + Firefox/Chromium Edge

Additional Info

For my account I have a repo listed FelixErnst/None, but this is of couse invalid, does not lead to github and also does not lead to a valid codecov page.

It seams to be the case, that the data is severly out of sync with GitHub.

I checked the developer console in my browser:

https://codecov.io/refresh/gh/FelixErnst?teams=no&repos=yes&taskId=

is called every half sec or so and returns a 204 status. So probably the refreshes do not work. I tried in Firefox and Chromium Edge

I deleted my account and reinstalled codecov on GitHub. Fixed it, but still not sure what the issue was.

1 Like

It sounds like a permission error of some sort. Glad you get it resolved.