Stuck on "Waiting for CI to complete"

Resposting here as requested from Stuck on "Waiting for CI to complete" · Issue #239 · codecov/codecov-action · GitHub


I work on multiple projects that use this action to upload, and I’m getting “Waiting for CI to complete” on many of them right now.

At first I was getting the “Unable to find commit in Github” error, but I fixed it as said in #190 (comment), but then, once I solved that, the “Waiting for CI to complete” message was still stuck there.


Commit SHAs


CI/CD or Build URL


Codecov GitHub action

Codecov Output

See CI\CD build url

Expected Results

No warning

Actual Results

“Waiting for CI to complete” warning banner on top of Codecov pages

@Jean85 does clicking the Push notifications now button in the build tab help?

No changes. All coverage uploads are already accounted for.

@Jean85 would you be able to push up a new commit so that we can investigate what’s happening for you here?

@tom done: Add whitespace · facile-it/terminable-loop-command@1bf86d1 · GitHub

Codecov page: Code coverage done right.

Any news @tom ? We’re still experiencing the same issue.

@Jean85, this is my mistake, this ticket got lost in my queue. Would you be able to push a new commit up, I’ll keep this one on the top of my list.

Actually, it looks like this is an issue with the app installation. If you go into the settings page for your repo, it should show you the issue.

If that doesn’t work, please try uninstalling and reinstalling the app again.