Can't see my own repos or organization I am owner of in codecov web app

Before submitting a topic, please confirm the following

I have searched for similar issues before creating this topic.
I have verified that my repository is using the Codecov GitHub app, if using GitHub
(N/A) I have validated my codecov.yaml configuration file.
I have filled out the below sections to the best of my ability.

Description

Trying to set up Codecov for a repository in a GitHub organization I am an owner in. I followed the Quick Start instructions including ensuring that

  1. Third-party application access for Codecov is granted for the organization (Neurobagel)
  2. GitHub app integration is installed for both my personal account and the organization
  3. Codecov is an OAuth authorized app in my personal GitHub account

I am able to log into Codecov with GitHub, but the organization I have granted access to (Neurobagel) is missing from the context drop down:

Furthermore, when I am in the context of my personal account (alyssadai), all of my repos are missing from the “Not yet setup” tab even after syncing is complete (as seen in the screenshot above).

My fellow owners of the Neurobagel organization (which is missing from my drop-down) did not encounter this issue. Interestingly, when I navigate directly to app.codecov.io/gh/neurobagel, I can see the public repos in the organization, but I do not have the option to set any of them up (i.e., I cannot click on any of them, and I only see “Not yet enabled” on the right-hand side).

Other things I have tried include:

  • Logging out and back into Codecov
  • Revoking and re-granting OAuth and third-party access to my account and the organization
  • Deleting and reinstalling GitHub app integration
  • Clearing cache + cookies, trying a different browser

Any help on this issue would be much appreciated. Thank you in advance!

GitHub username: alyssadai

CI/CD URL

N/A

Codecov Output

N/A

Expected Results

That the GitHub organization I am an owner in/have admin permissions in appears in the context drop down in the Codecov web app.

Actual Results

One of my organizations is missing from the context drop down.

Additional Information

Hi @alyssadai, sorry for the delay here. Looks like a bug on our end, I’ll look into it and reply when we’ve got it fixed.

1 Like

@alyssadai sorry for the delay. We are still trying to debug this issue. I’ll get back to you if I have any questions or information. Sorry it’s taking so long.

1 Like

@alyssadai, ok we found a bug around login that might have affected this. Would you be able to log out, clear Codecov cookies, and try logging back in?

Hi @tom, thanks for getting back to me. I just tried this, as well as revoking and re-granting OAuth access to the organization I’m trying to access, and it unfortunately still doesn’t seem to work. I still only see my personal profile context (without any of my repos inside it, for whatever reason), and my other organization (CobraLab) as in the first screenshot.

@alyssadai ok, I think we found another underlying issue. Thanks for your patience here.