Codecov team list not updating with my GitHub Org

Description

I am the owner of a GitHub org and I want to have Codecov be run on one of the repos in it. I have granted access to Codecov in my team list on GitHub, but when I view my teams list in Codecov the GitHub org does not show up. The Codecov page for the team and the repo exist but Codecov does not seem to understand that I am the owner as I do not have access to the Settings tab like I do in my other teams.

Repository

Steps to Reproduce

  1. Visit teams page on Codecov.io

Expected behavior: See my GitHub org in the teams page and have permissions

Actual behavior: No permissions to my GitHub org on Codecov.io

Flakiness? This happens all the time

Versions

Google Chrome on Ubuntu 19.10

$ uname -a
Linux thinkpad 5.3.0-40-generic #32-Ubuntu SMP Fri Jan 31 20:24:34 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
$ google-chrome --version
Google Chrome 80.0.3987.132

Additional Information

My permissions on all of my other teams seem fine.

Happening to me too.
GH team syncing spinner never completes.

Hey @filipesperandio and @matthewfeickert I’ve confirmed that the Team Sync button on Github is spinning permanently currently. Thanks for bringing it up.

I’ve raised this issue internally.

@matthewfeickert --> I’m not positive this will solve your admin access issue, but I believe it should.

Jerrod

1 Like

@filipesperandio @matthewfeickert the team sync button and repo sync butttons are now working as expected.

If you are still seeing permanent spinning of the sync icon, please log out and log back in as your account may be in a cached state.

Hi,
I’m having the same issue. Even after revoking access and explicitly granting codecov extra permissions for new organisation it doesn’t show up in the list. The spinner gets stuck forever in updating github teams.

Hi @Maxim-Filimonov please open a new issue for this.

1 Like

I’m having this issue too. The list is not updated, and the loader is stuck on syncing. It’s showing old repositories, and new ones aren’t being reflected after clicking on the ‘Not yet setup’ tab.

Please open an issue for this, or redirect me to an active issue.

I’m having what I assume is a related problem – going to codecov.io/gh, the spinner spins forever. I just added the Codecoc Github App to a new organization, and the organization is not showing in the dropdown list on codecov. I have cleared the cache, logged out/in, nothing seems to help.

I accidentally posted my related issue (renaming of Github repo in organization) in the Support section, but it might be worth to cross-link it here: Codecov does not show project after renaming it in GitHub

Update for me: if I go to the page of the organization I added (http://codecov.io/gh/halomod) it exists now, but it still doesn’t show in the dropdown.

@steven-murray do you mind taking a screenshot of what you mean here, I’m not sure I quite understand.

Hi @tom, the “dropdown” I mean is this one:

The entry “halomod” does not appear there, but if I go to the URL I listed it appears (sorry, can’t post image apparently)

I am also able to reproduce this on a new organization. Doesn’t show in drop-down but I am able to view it by going to the URL.

@steven-murray, @strideynet just want to check if following these instructions causes the org to show

Hi @tom, yes, it worked after I went to my “Authorized OAuth Apps” tab on github, Revoked access to Codecov, then logged into Codecov, and on the login screen thing clicked “Grant” access to the halomod org.

Thanks for helping out! I should not that this is a highly non-intuitive action to take, and clearly I didn’t find the help page you linked to. Not sure if there’s a way to fix that, but I’ll let you guys deal with that :wink:

@steven-murray totally understand, this has been a new thing from GitHub that we have been trying to solve in-product. Thanks for the patience and understanding.