Renaming organization leads to 404 in project's settings page


Renaming organization leads to 404 in project’s settings page.
I want the badge. But it doesn’t update.


Notice that the new organization name is 888Games and the old one is TCI-2019-g66.


I can’t put more than 4 links :man_shrugging:t3:


Windows 10 Chrome Version 79.0.3945.130 (Official Build) (64-bit)

Additional Information

It’s my first time using CodeCov. Maybe I’m doing something wrong.

Hi @mauriciabad

Welcome to Codecov! No, you aren’t doing something wrong, due to the way that GitHub exposes org renames, they are tricky to handle by third parties such as Codecov.

Can you uploaded coverage since the rename? Are you using the Codecov app on GitHub, and if so, have you confirmed it’s still allowed in third-part restrictions?


I think I have the same problem. I had to rename an org I was trying to use codecov on, and after the switch I get 404s in the settings panel, and I can’t push coverage reports anymore. It also doesn’t list the org’s repositories anymore when I go to codecov settings urls with the old org name.

Any way I can fix this?

Hey Paul: can you check your 3rd party installed apps?

And try reinstalling Codecov there? If that doesn’t work, we can try a manual rename on our side (we do rely on the Github org name as the central connection point in DB, e.g., no unique orgid coming from Github).


Hey Jerrod,

I’m not sure why but it works now. Maybe it eventually picked up on the renamed org. Coverage reports make it through now.


I have the same problem after renaming a repository, not the org:

I would delete it completely but going to settings returns 404

I have the same problem after transferring a repo across organizations and renaming it.
Codecov is installed in the github org and has access to the repo


Hi codecov support team, I have same problem and re-installing doesn’t fix my case.

After uninstalling GitHub App (, it’s stuck showing “Syncing GitHub Teams” at . The old org name doesn’t disappear and new one never appear even if installing the GitHub App again and again.

Thank you,

↑ It looks to be solved right now! Great thanks :partying_face:
I was doing nothing, so maybe support team might have done something.

1 Like

Sorry for this @Luma. Sometimes it takes some time for the repository change to take effect.

1 Like