How to update project URL after moving GitHub repo to an organization


I’ve moved my project repo from to, and I don’t see Codecov checks in a new PR that I just made.

When I enter “Settings” tab in Codecov, I see:

Oops, something went wrong

Github API: Moved Permanently.
Check on Codecov’s status or see our docs for common support.

Error 301

How can I update the URL?



GitHub Actions


Bash uploader

Commit SHAs


Codecov YAML

No YAML - default settings

Codecov Output

Codecov output is missing

Additional Information


Hi @pzelasko, the settings page should now work as we patched this issue.

As for status checks, I believe this is a permissions issue. Are you using the GitHub App Integration?

I was not using GitHub App Integration, but I have just enabled it. I was using the “older” integration mechanism before (I don’t remember what it was called).

After the patch, I don’t see the settings at, but I see an option to go to “Organization settings” (lhotse-speech) when I click on my avatar - however, I’m getting Unauthorized 401 status when I try it (I own the organization).

@pzelasko, can you try clearing your cookies and re-logging in? Let me know if that doesn’t work.

It didn’t help. Although when somebody opened a new PR, I saw that the CI integration returned (after enabling Codecov GitHub App). So it seems everything works, I just don’t have the access to the organization/settings tab, I guess I can live with that…

@pzelasko, this looks like a permissions issue. Can you try logging out, deleting cookies, and logging back in?

I tried to log in using a private browser window that has no cookies - no success… After the log in, it says I have no repositories (as user pzelasko); the organization (lhotse-speech) is not even displayed.

@pzelasko, I’m really sorry that it’s not working for you. This is definitely a permissions issue. Would you be able to log out, remove cookies, and revoke Codecov access here. And then try logging back and re-grant permissions?

Seems to have solved it - thanks a lot!

1 Like

For anyone looking to solve this problem. Check your CODECOV_TOKEN. It has to be replaced in GitHub repo secrets for the uploads to work with the moved Codecov project :man_facepalming:

1 Like